Game Freezing

L99_pat

Poster
Hey guys, just wondering if anyone else has been getting this problem since the update a few days ago:

My game keeps freezing and the sound loops when it does for about 10 seconds. It does it 3 times continuously, so about 30seconds in total. First it did once a day, now it's doing it every 10-15~ mins.... in the console I get this message:

Error reading weapon data file for: weapon_ifm_steadycam

Is anyone else getting this? And does anyone by any chance know any solutions to this? I opened a steam support ticket but steam takes forever.

Thanks,
-Pat
 

ronpaul

EGO Zealot
Can you enter console while the sound is looping?

try:

-Verify game files
-defragging local files
-record a demo for a few seconds, stop the demo
-check your %steamprofile%/dod/scripts folder for the file, delete it

Are you using custom scripts, skins, or models?

EDIT: it's probably custom content that the engine doesn't like anymore, revert to factory settings, add your custom stuff one item at a time until you find the problem one, then just avoid using that.

Better idea: join a server that uses sv_pure 1, a lot of realism servers use it, that'll strip away all your custom stuff. If you don't get the error, you've found the problem, follow steps above.
 
Last edited:

Dark_Fife

Poster
i has happen to me in the past and im not in game right now because my game went in to loop and then my computer died :(
 

Kiwi

Thread Junky
Better idea: join a server that uses sv_pure 1, a lot of realism servers use it, that'll strip away all your custom stuff. If you don't get the error, you've found the problem, follow steps above.
how do I find a server with this?
 

ronpaul

EGO Zealot
how do I find a server with this?
I don't know of a way to actively filter a server list to find this. The variable doesn't even show up in the HLSW cvar list. If you just want to test this, send me a PM and i'll give you my server address which I'll set to pure for you guys. Other than that, the next best thing is filtering the dods server list by searching for "Realism" in the name, those are usually pure.
 

L99_pat

Poster
I tried verifying and defragging. Also this happened before I installed my custom skins. I got rid of them all and tried again and the same thing happened. And no, I cannot enter in console when the sound is looping.

Also I have no script folder inside my dod folder. Even when I search the file in question (weapon_ifm_steadycam) I can't find it anywhere..... I wish steam support would answer.
 
Yeah this is happening to me also.. locks up for a bit then unfreezes with that sound looping... used to get a bad to mild case of this everytime i updated my Video card drivers..

Ended up having to reset the Graphic Card's Control Panel back to normal(Application Controlled .. instead of Force X4 Anti Aliasing and crap for some reason it would default to that every-time.)

Don't know why this is happening now but it's really annoying. Was just fine yesterday. lol
 
Top