DOD runs like crap, help needed.

El Che~

I made one post
Heres the story

got home from work, computer off. Odd considering I havent turned it off in a month or so. I turn it on it loads windows then turns off. Same thing when trying again.

Switched out power supply. Turns on, nothing on the monitor. The HD doesnt sound like its running either. Unplugged everything ecept the monitor. Nothing

Moved hd to another computer, its fine. So im pretty sure while switching power supply's a static change fried some part of the mobo.

Ok thats cool, ill jsut play on the other comp. I try running the game from the moved HD without actually installing it. Load the main menu screen, but dont play as im running the on board video. Install grapics card, install the game correctly.

"Not the current drivers"
install updated drivers
game doesnt load at all
try to roll back drivers and reinstall old drivers
No drivers for the current hardware. WTF ok...

remove graphics card, uninstall all nvidia whatnot, restart, uninstall onboard video again, reinstall nvidia drivers again

Cannont find XXXXXX.dll (nvidia related)

ok whatever, REFORMAT
Fresh windows install
Update BIOS, and mobo drivers
install updated nvidia drivers
install Source and DOD:s

sweet motherofjesus the game runs.

get on avalance server, and it looks like my ping is 1000 or something.
set min settings, with 800x600 res
do whatever was in the stickys about fixing your choke.

Game just as bad, join a server with no people and it seems fine, problem only when near other players or shooting mg or explosions

so ok maybe this comps a bit slow
add another 512 ram (1gb total now)
overclock the cpu up to about 2.8 ghz
up the up the ghz of the ram

game runs fantastic at 1600X1200 with HIGH settings (anti aliasing off)
in an empty server, but still runs like a crackhead who lost his wooden leg in any other game. (keep in mind my ping is never over 75)

Comp specs:
Intel Celeron 2.61ghz
DDR 1gb 266mhz(2 sticks 512, same brand)
Western digital 160gb IDE HD
Biostar P4M800 Pro-M7 MOBO

The comp I had wasnt far of and DOD ran great. (had DDR2 400mhz)

So is the comp too old? Am I missing something? Does GOD hate me?
Any advice welcome. Cant upgrade my old comp for a month or so, im outta the game until then if I cant fix this.
Looks like its the processor, Celeron D is just too old I guess. Ill be back when I grab a new Mobo then
have you tried re-seating the RAM in the computer that is having issues ? how about reseating the video card ?

have you tried resetting the CMOS ?

are you sure that your PSU is set to the correct power output (usually a little red switch on the back of the PSU)
and it might be possible that the PSU you installed later to test did not have enough power.

does it make a beep?
is there a green or red light on your motherboard ?